Supported Devices

WorkPlan is supported on most mobile phones or tablets running Android version 4.4 or later, or iOS version 10 or later.

If you are using WorkPlan as an ELD with a Bluetooth device, your device must be Bluetooth LE capable. If you are using WorkPlan as an ELD on Android, we recommend version 6.0 or later.

Consult with your Verizon Connect representative to help with recommendations for phones or tablets that will suit your work flow and environment.

Subtle user interface differences exist between WorkPlan installations, depending on the specific mobile device it is installed on. Because of this, the screen shots in this help system might differ slightly from the screens you see on your device.